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WELCOME 
Bently Nevada is pleased to present System 1 v20.1. This release delivers major new capabilities to the OT/IT 
System Integration, Diagnostic HMI, and General Machinery Monitoring use cases provided by System 1. In 
addition, several customer-requested diagnostic and productivity enhancements have been added to other 
key use cases. For an overview of the System 1 platform, please refer to the System 1 Website. 

 
 

OT/IT System Integration 
OPC UA Export – Static Data and Alarm Events 

System 1 OPC UA Export has been extended to support static data (numeric) export from System 1 
to OPC UA Clients. In addition, Alarm Event export has also been added. All Alarm Events are 
exported, with supporting details including Entered/Exited timestamps, acknowledgement 
information, and latch status. All other Event types are not yet supported, including: 

• System Health (e.g. Device Not Communicating, TIM not responding) 

• Transient (e.g. Entered Startup, Exited Shutdown) 

• User Initiated (e.g. Entered Suppression, Monitor configuration updated) 

OPC UA Export is supported on both Tx and Rx Servers. NOTE: OPC UA Export is not supported for Offline 
Databases or those licensed with the Fundamental Package. 

This extension of OPC UA capabilities enables customers to interface the rich dataset of System 1 with 
external data stores for further analytics and enhanced asset insights. 
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OPC UA Static and Alarm Event Export is available as a new entitlement:  

• Perpetual = 3071/15-AA-BB-CC-DD (CC = qty of OPC UA Static Data Servers, DD = qty of OPC UA Alarm 
Event Servers) 

• Subscription = 3072/15-AA-BB-CC-DD-EE-FF (EE = qty of OPC UA Static Data Servers, FF = qty of OPC 
UA Alarm Event Servers) 

 

Diagnostic HMI 
Modbus Import – Modbus import has been added as part of v20.1, enhancing System 1’s capabilities for 

collecting all asset health data, including Process, Control System, and Emissions data. 
Customers can now avoid the extra step of converting Modbus to OPC, eliminating configuration 
costs and long-term infrastructure maintenance. Up to 15,000 tags can be imported into a single 
System 1 database and 20% of those tags can be configured to store at rates of up to 200ms! 

NOTE: Modbus Import is not supported on Rx databases. 

With native Modbus support, it is even easier for customers to use System 1 as a Diagnostic HMI, visually 
depicting Asset Health within the context of its supporting sub-systems. 

Modbus is available as a new entitlement: 

• Perpetual Part Number: 3071/14-AA-BB, where BB = Modbus Import license 
• Subscription Part Number: 3072/14-AA-BB-CC-DD where DD = Modbus Import license 

 

General Machinery Monitoring 
Trendmaster SPA Import – System 1 v20.1 adds new TIM and 1900 Monitor support, enabling customers 

with the most common types of Trendmaster devices to migrate to the new System 1 
platform. Many customer-requested capabilities have also been added, including 
alarm data capture, data on-demand, and alarm setpoint download to the DSM 
hardware. 

Trendmaster devices have been deployed globally to enable more real-time monitoring of general 
machinery. With native integration, customers can take advantage of all of the rich capabilities of System 
1 and achieve plant-wide asset monitoring within a single platform. 

Trendmaster SPA import is enabled for new customers through license (3071/13-DD) and is licensed per 
TIM. Existing System 1 Classic customers with an Active M&S agreement are entitled to upgrade 
standard procedure (3071/65). 
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Complete New Capability List 
Users upgrading to v20.1 will also benefit from several other improvements to the platform, as outlined in the 
image below. 

 
Bently Nevada remains laser-focused on delivering the world’s premier plant-wide machinery management 
application with bi-annual product releases. 

 

Thank you, 

Your System 1 Leadership Team 
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 SYSTEM 1 V20.1 FEATURE OVERVIEW 

 
Table 1: System 1 v20.1 – Connectivity Capabilities 

Connectivity 

Bently Devices 
Trendmaster 
DSM 

Support for additional channel types from TIM family. New capabilities 
also include data on demand and alarm data capture. 

3.1.1 

Interfaces 

OPC UA Static & 
Setpoint Export 

Export Static Data, including Setpoint configuration, from the System 1 
database to external systems. 

3.2.1 

OPC UA Alarm 
Event Export 

Export alarm event data from the System 1 database to external 
systems. 

3.2.2 

Modbus Import 
Connect with Modbus devices and import data into system 1 which 
includes  sub-second data collection & state-based storage.    

3.2.3 

Data Management 

Proficy to Postgre 
Data Migration 

Migrating data from Proficy to PostgreSQL for existing System 1 database  3.3.1 

User 
Management 

Edit rights assignments to the Advanced and Basic Roles. NOTE: 
Administrator Role has all rights. 

3.3.2 

Template 
Import/Export 

Export/Import user-defined templates between Databases, enabling 
efficiency and consistency with configurations across sites. 

3.3.3 

Replication Data 
Repair 

When data transfer from the Tx to Rx is disrupted, manually repair 
replication to move missing data from the Tx to Rx database. 

3.3.4 
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Table 2: System 1 v20.1 – Analytics Capabilities 

Analytics 

Core Alarming 

Bulk Setpoint 
Import/Export 

Modify multiple condition monitoring alarm setpoints in bulk using file-
based configuration (CSV). 

4.1.1 

Alarm Quick 
Config -  
State Filtering 

When state-based alarm set is selected during Alarm Quick 
Configuration, only data from that state is included for statistical 
setpoint calculation. Only available with PostgreSQL. 

4.1.2 

Suppressed 
Events List 

A new "Suppressed" tab has been added to the Events workspace, 
showing all events that have been suppressed at or below the active 
hierarchy selection. 

4.1.3 

Alarm Summary 
Measurement 

Add alarm summary measurement at a database, group or machine 
train level to get count of un-acknowledged alarms at each Alarm 
Level. 

4.1.4 

Decision Support 

Decision Support 
Beta 

Beta with basic functionality for internal testing and targeted 
customers. Release 1 of Decision Support - August 2020. 

4.2 

Table 3: System 1 v20.1 - Visualization Capabilities 

Visualization 

Plots 

Logarithmic 
Scales 

Support for converting to logarithmic scales on Spectrum, Stacked 
Spectrum, XvsY, and Recip (PV curve) plots 

5.1.1 

Plot Theming 
Customize plot colors and styles, as per user’s choice. Includes curves, 
cursors, and plot foreground/background 

5.1.2 

Orbit on Shaft 
Centerline Plot 

Overlay the closest orbit sample (based on cursor location) on top of the 
shaft centerline plot. 

5.1.3 

Polar Plot 
enhancement 

Display vector cursor and keyphasor notch on Polar Plot. 5.1.4 
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 VERSION SUPPORT & OPERATING SYSTEM COMPATIBILITY 
Release Cadence & Version Support 
System 1 follows a semi-annual release cadence with targeted releases in April/May and October/November 
of each year. Versions are fully supported for a minimum of 2 years from the published date of availability 
(Table 4). 

New Versions of System 1 Benefit from: 
• Compatibility with the latest Microsoft Client & Server Operating Systems 
• Client backwards compatibility to previous versions under support 
• Database upgrade from previous versions released within last 3 years 
• Security patch & update testing for the latest available version 
• Bug fixes included in the latest available version 
• Standard technical support with escalation to engineering as required 

Versions no longer supported: 

• Standard support is provided for common FAQ type questions, but users are encouraged to update 
software to latest version to benefit from new features, OS compatibility, and bug fixes. 

Table 4: System 1 Version Support & OS Compatibility Matrix 

System 1 Versions & Support Windows Server OS Windows Client OS (64bit) 

Version Available End of Support 2019 2016 2012 R2 2012 2008 R2 10** 8.1 U1 7 SP1 

20.1 May 2020 Q2 2022 ü ü ü ü  ü ü  

19.2 Nov 2019 Nov 2021 ü ü ü ü ü ü ü ü 

19.1 May 2019 May 2021 ü ü ü ü ü ü ü ü 

18.2 Dec 2018 Dec 2020  ü ü ü ü ü ü ü 

18.1 Jul 2018 Jul 2020  ü ü ü ü ü ü ü 

17.2 Nov 2017 Nov 2019  ü ü ü ü ü ü ü 

**Windows 10 version compatibility will track Microsoft’s published release and support model. The latest 
version of System 1 will be tested and supported on all versions of Windows 10 under support as published on 
their website based on the System 1 version’s published date of availability. 

System 1 v20.1 (Windows 10 v1903, 1809, 1803) 

System 1 v19.2 (Windows 10 v1903, 1809, 1803) 

System 1 v19.1 (Windows 10 v1809, 1803) 

 

System 1 v18.2 (Windows 10 v1803, 1709) 

System 1 v18.1 (Windows 10 v1803, 1709, 1703)
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 CONNECTIVITY 

 Bently Devices 

Trendmaster DSM video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

3.1.1 Trendmaster DSM 

System 1 v20.1 adds support for new channel types from the TIM (Transducer Input Module) family and 1900 
monitors (Table 5). Customers can now migrate configuration and data for supported channel types, 
including spectral band configuration, setpoints, and data. 

In addition, System 1 v20.1 extends Trendmaster capabilities with features like data on demand, CM alarm 
setpoint download to hardware, and alarm data capture for DSM. The v20.1 release also includes the DSM 
Modbus Utility, allowing users to configure Modbus registers in the DSM hardware and export data and alarm 
status over Modbus protocol.  

Table 5: Supported Trendmaster Channel Types (see Data Sheet for HW P/N) 
TIM 19.2 20.1 

ProTIM 

Accel to Velocity Point 
Low Frequency Accel to Velocity Point 
Rack Buffer Output ProTIM 
Temperature Point: 2-3 wire Platinum RTD 
Temperature Point: TC K Type 
Speed Input: Keyphasor 

Displacement Point 
Pressure Point 
Process Points 
Accel to Velocity with AE (Acceleration Enveloping) 

FlexiTIM 

Accel to Velocity FlexiTIM 
100 Ohm Platinum RTD FlexiTIM 
J Type TC FlexiTIM 
K Type TC FlexiTIM 

 

TIM 

 Displacement Point 
Keyphasor Point 
Process Points 
Rack Buffered Keyphasor Point 
Rack Buffered Output Point 
Accel to Velocity Point 
Velocity Point 
Type J Thermocouple Temperature Point 
Type K Thermocouple Temperature Point 

1900 
Monitors 

 1900/25 Velocity Monitor 
1900/55 Fan Monitor 
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 Interfaces 

3.2.1 OPC UA Static Data and Setpoint Export 

OPC UA Static Data and Setpoint Export video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

Static Data Export 

System 1 v20.1 extends OPC UA Export to static data from all configured Trended Variables within a System 1 
database. This export includes the State Variable, which tracks the Operating State information (e.g., Running, 
Slow Roll, Machine Off). To view static data, users can subscribe to the Trended Variables node in the System 1 
OPC UA address space from any OPC UA compliant client to view static data. The measurements, along with 
units and subunits, are exported (Figure 1). 

The fastest data export rate is the configured data historization rate within System 1. 

 
Figure 1: System 1 Trended Variable Data in OPC UA Client 

Setpoint Export 

As a part of OPC UA Static Data export, configured Setpoint values can also be exported. Setpoints are visible 
as a part of the OPC UA address space, under the respective Trended Variable node in the System 1 
Hierarchy (Figure 2). All configured setpoints are available for export, including Protection, Standard Condition 
Monitoring, and State-Based Condition Monitoring. 
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Figure 2: System 1 Setpoints in OPC UA Client 

3.2.2 OPC UA Alarm Event Export 

OPC UA Alarm Event Export video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

In System 1 v20.1, Machine Alarms (Level 1, 2, 3, 4) and Channel Not OK Instrumentation Alarms can be 
exported using the System 1 OPC UA Alarm Events Server to any OPC UA compliant client. Users can subscribe 
to any node of the System 1 Hierarchy available in the OPC UA Client address space. Information will be 
updated in the OPC Client for the subscribed nodes when an Alarm Enters, Exits, is Acknowledged, Latched, or 
the Latch is Reset (Figure 3). 

 
Figure 3: System 1 Alarm Event Data in OPC UA Client 
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3.2.3 Modbus Import 

Modbus video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

In System 1 v20.1, process data can be imported via the Modbus TCP protocol. To add a Modbus Device, right-
click on the Devices Node in the Configuration workspace, and select Modbus. The workflow for adding 
Groups and Points mirrors that of OPC and leverages bulk CSV import. Up to 15,000 Modbus and/or OPC 
points are supported in a System 1 database. 

System 1 collects data from Modbus devices at the data collection rate configured for a Modbus group. With 
PostgreSQL as the Historian, customers can configure up to a 200 ms collection rate for 20% of the Modbus 
points within the database. When Modbus tags are mapped to an asset with configured Machine States, 
data can also be stored at sub-second storage rates when the asset enters the defined state (Figure 4). 

For points with sub-second collection rates, alarming and state triggering will occur at the sub-second rate. 

 
Figure 4: Modbus Group and Storage Rate 

 Database Management 

3.3.1 Proficy to PostgreSQL Data Migration 

Migration video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

In v19.2, PostgreSQL has been offered as an alternative historian technology. For new System 1 installations, 
Proficy will not be installed and only a System 1 license is required. For existing System 1 installations, 
upgrades will retain Proficy as the Historian.  

In v20.1, customers with existing System 1 databases now have a tool to switch current Historian from Proficy 
to PostgreSQL for creating new databases with PostgreSQL as Historian and migrate Proficy data for existing 
System 1 database to PostgreSQL via Migration Tool. 

Switch Default Historian to PostgreSQL 

• Launch System 1 Database Manager as Administrator 
• Select File > Preferences 
• In Historian Tab, select PostgreSQL from Historian dropdown dialog (Figure 5) 
• By clicking Save, all news databases will utilize PostgreSQL 
• Note: Historian tab in Preferences dialog is only displayed when the default Historian is Proficy 
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Figure 5: Changing Default Historian in Database Manager 

Proficy to PostgreSQL Data Migration 

• Launch System 1 Database Manager as Administrator 
• Select Proficy Database Migration from Tools menu (Figure 6) 
• Browse and select the desired System 1 Database and click on Migrate (Figure 7) 
• After clicking on Migrate button, it shows the progress in terms of % completion (Figure 8) 
• Once migration is complete, a Summary screen is shown. As noted in the dialog, System 1 Services 

must be restarted (Figure 9). 

 
Figure 6: Proficy Database Migration option in System 1 Database Manager Tools 



Welcome to System 1 “Version 20.1”  

 

Copyright 2020 Baker Hughes Company. All rights reserved. Page 14 of 30 

 

 

Figure 7: Proficy Database Migration – Browse Database 

 
Figure 8: Migration Progress in % completion 
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Figure 9: Migration Completed 

Move Proficy Database Due to Low Disk Space 

• In the case of low disk space, an Insufficient Disk Space message will be shown (Figure 10) 
• After selecting Yes to proceed, the user can browse to an external hard disk or network drive to move 

the existing Proficy data store. Click Move to initiate the database move. 
• Once the Move is complete, the Migrate button will be enabled to continue with the migration. 

 
Figure 10: Move Data message when Insufficient Disk Space for Migration 
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3.3.2 User Management – Edit Rights 

User Management video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

In prior releases, users could view rights assignments to each role, but these assignments could not be 
modified. With the v20.1 release, rights are now customizable. Users with the Edit User Settings right can 
modify the assignments for the Advanced and Basic Roles. To modify rights, launch Database Manager and 
select Tools > Server Security. Within the Roles tab, Check/Uncheck to assign rights to the Advanced and 
Basic Roles (Figure 11); the Administrator Role is assigned all rights and cannot be modified. 

To view assignments within opened databases, select Tools > User Management and select the Roles tab. 

 
Figure 11 : Roles and Rights in Server Security 
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3.3.3 Template Import/Export 

Template Import/Export video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

User Defined Machine Templating has been supported within System 1 for many releases. It is important to 
note that two template types exist: 

 For machines with only Portable Points, Templates include all associated asset properties, 
measurements, and setpoints 

 For machines mapped with Online Device Points, Templates only include asset properties 

With the release of v20.1, users can now export user defined templates from one System 1 Database for 
import into a separate Database. Template Import/Export allows users to export both template types, along 
with any saved User Defined plot sets. 

Export Templates 

To export templates:  

• Launch the Tools > Custom Components dialog and select the Templates tab, which lists all user 
defined templates within the database (Figure 12) 

• Select the templates you want to export & click on the Export Icon  
• In the File Browser window, select the location where you want to save the exported template file 

(*.s1t) and click Save 
• Transfer the created file to a location accessible to other System 1 Servers 

 
Figure 12: Import/Export Template from Custom Component Manager 
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Import Templates 

To Import Templates: 

• Click on the ‘Import Template’ button in the Tools > Custom Component Manager dialog when in the 
Templates Tab.  

• Select the *.s1t file, select the desired template to import, and click ‘Import’ (Figure 13) 
• All selected templates, along with their plot sets, will be imported into the System 1 database 
• The imported templates will be displayed in the User Defined Templates section of the Configuration 

workspace, as well as in Template Mode and are available to use for new machine instances. 

NOTE: If a template with the same name is imported, the existing template will be overwritten and all the 
linked instances updated. 

 
Figure 13: Import Templates Dialog 

3.3.4 Replication Enhancements 

Replication Enhancement video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

In System 1 v20.1, PostGreSQL database users can manually repair data that failed to replicate between Tx 
and Rx Servers, due to network or computing unavailability that impacted the Replication Service. This 
feature can also be used to retransmit data, including historical data migrated from System 1 Classic to 
System 1 20.1 prior to replication being enabled. 

In addition, two other enhancements have been made: 

1. A new system health notification has been added to let users know if files are being received correctly 
by the Rx System 1 replication service. 

2. “All Data” has been set as the default replication setting when configuring new Tx Servers. This option 
has been extended to Dynamic Data, ensuring all stored waveforms are transmitted to the Rx Server. 
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 ANALYTICS 

 Core Alarming 

Alarming video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

4.1.1 Bulk Setpoint Import/ Export 

In System 1 v20.1, alarm setpoints can now be modified external to System 1 via File Based Configuration (FBC). 
To export setpoints, right-click on a hierarchy component in the Machines or Devices hierarchy and select 
Configure Alarm Setpoints > Export Setpoints (Figure 14). This will launch a File Browser for saving the .csv file. 
Opening the file with Excel allows users to leverage its rich data manipulation capabilities for bulk setpoint 
editing. 

To import the .csv file, right-click on the same hierarchy component and select Configure Alarm Setpoints > 
Import Setpoints. The setpoints will be imported, with a summary provided through a log file. 

 
Figure 14: Configure Alarm Setpoints 

4.1.2 Alarm Quick Configuration – Filter by State 

Alarm Quick Configuration, introduced in a prior System 1 release, enables users to leverage historical asset 
data and simple statistics to configure Condition Monitoring setpoints that reflect the behavior of that asset. 
Unfortunately, when used to configure State-Based Alarms, all historical data within a time range was used in 
the calculation, instead of filtering to only the data from the defined state. 

With the 20.1 release, when a state-based alarm set is selected in Alarm Quick Configuration, only data from 
the associated state is used as part of the setpoint calculation (Figure 15). 

NOTE: This is only supported for databases with PostgreSQL as the data historian. 
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Figure 15: Alarm Quick Configuration, with Startup/Shutdown Selected as Alarm Set 

4.1.3 Suppressed Events List 

Event suppression can be leveraged to reduce nuisance alarms. The ability to Suppress Events was added in 
v19.1. However, there was nowhere within the System 1 workspace to view events that had been suppressed. 
With v20.1 release, a new Suppressed tab displays all events that have been suppressed for the current 
hierarchy selection, providing more visibility into the status of alarms within the Condition Monitoring 
program (Figure 16). 

 
Figure 16: Suppressed Events List 
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4.1.4 Alarm Summary Measurement 

Alarm Summary Measurement video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

With System 1 v20.1, users can monitor the count of un-acknowledged alarms along with their statuses (Have 
New alarm- True /false) for each alarm level (Level 1->Level4) via alarm summary measurements. These 
measurements mimic the decision support rule logic that our customers use in System 1 classic. 

To add Alarm Summary Measurements, right-click in the Hierarchy at the Database, Group, or Machine Train 
level and select “Add Alarm Summary” (Figure 17). 

 
Figure 17: Add Alarm Summary 

An “Alarm Summary” point will be added as a child of the hierarchy node, along with 13 alarm summary 
measurements, which can be viewed in the Measurements > Trended Variables workspace (Figure 18). The 
measurements are: Count of Unacknowledged Alarms (Level 1-4), Count of Suppressed Alarms (Level 1-4), 
Status of Unacknowledged Alarms (Level 1-4), and overall “Status of Alarms”. The measurements are 
calculated every 30 seconds. 

 
Figure 18: Alarm Summary Measurements 
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User can trend the Alarm Summary Measurements, along with their status, in List View, Bar Graphs, and the 
Plotting Workspace (Figure 19). These measurements can also be exported using OPC DA or UA protocols. 

 

Figure 19: Alarm Summary in Display Workspace 

Advanced settings can be configured to control the output of the Alarm Summary Measurements. Refer to 
System 1 Help for more details. 

 Decision Support 
Decision Support is a standalone software product designed to run on the System 1 Server and perform 
mathematical and logical analyses on System 1 data quickly and reliably. The first release of the newly re-
platformed Decision Support will be compatible with System 1 v20.1 and available in August 2020. In this first 
release, it will be available to run on a Tx System 1 Server against an Online Database (Figure 20). 

 

Figure 20: System 1 and Decision Support Integration 

Decision Support provides a platform and an analytic toolset for evaluating and deriving data that can be 
used to enhance and automate your condition monitoring program. A graphic interface allows knowledge of 
common machine faults to be codified into a set of rules, thereby simplifying issue identification and 
decision making. Inputs and outputs are defined and mathematical and logical blocks are used to compare 
values, introduce constants, and calculate results. This user-friendly interface allows users to quickly program 
and fine tune Rules so that they suit the machinery processes and conditions at hand. 

Once built, Rules can be Deployed - using the Decision Support Client - to an asset in the machinery 
hierarchy of System 1. The resulting trended variables are returned to System 1, where the user can leverage 
the rich alarming, trending, and notification capabilities to drive work items related to machine and process 
conditions detected by Decision Support. Rule Results can also be incorporated into System 1’s Diagnostic 
HMI views to visualize key metrics within operator views. 

Decision Support enables customers to embed the knowledge of their experienced experts within System 1, 
multiplying this knowledge across the asset fleet and ensuring it is retained long-term. 
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 VISUALIZATION 

 Plots 

Plot Enhancements video located in Bently Nevada Tech Support Training Library 
Valid M&S Agreement Required 

5.1.1 Logarithmic Scales 

Logarithmic (a.k.a., log) Scales within the Plots workspace is now supported! This capability is available for 
System 1 Client version 20.1 and is backwards compatible for System 1 Server databases up to v18.2. It is 
applicable for the following Plot Types: Spectrum, Stacked Spectrum, XvsY, Recip Plot (PV curves). 

This capability can be applied both globally within a plot set, as well as locally on an individual plot. To apply 
Log scales globally, use the hotkey “L”. On pressing the hot key, the scales will toggle in the following order: 

• Logarithmic Y-axis, only 
• Logarithmic X-axis, only 
• Logarithmic Y and X axes 
• Both axes back to linear scales 

To apply log scales locally, right-click on a supported plot and select “Scales > Logarithmic Y-axis / 
Logarithmic X-axis”, (Figure 21). To remove log scales locally, right-click on the plot and deselect the enabled 
settings. Log scale settings are preserved within User Defined Plot Sets and Plot Records. 

For the Reciprocating plot, there is a single option in the context menu, “Scales > Logarithmic X-Y” (Figure 22). 
In Reciprocating plots, log scales are only applicable to P-V curves. 

 
Figure 21: Logarithmic Scales Options from Local Context Menu 
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Figure 22: Logarithmic Scales Option on Reciprocating Plot 

5.1.2 Plot Theming 

With the release of System 1 20.1, Theming has been extended to the Plots Workspace. Theming can be found 
within the “Theme” tab of Preferences (Figure 23). 

 
Figure 23: Theme Menu in Preferences Dialog 
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Two themes are supported in v20.1: 

1. Default: This option is non-editable and reflects the System 1 default theme. 
2. Custom: This is a user customizable theme. To edit, select Custom and click the Edit icon in the top 

right corner of the window, which will launch the editing dialog. 

Within the Plots tab, the user can customize the Primary and Secondary Curve Styling, Cursor Styling, and 
Overall Styling. 

For Primary and Secondary Curve Styling, there are three options that can be customized (Figure 24): 

1. Curve Color 
2. Curve Thickness 
3. Line Style 

 

Figure 24: Editing the Primary Curve Style 

For Cursor Styling, there are again three customization options (Figure 25): 

1. Cursor Color 
2. Cursor Width 
3. Cursor Height 
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Figure 25: Editing the Cursor Style 

And finally, there are three customization options within Overall Styling (Figure 26): 

1. Plots Background 
2. Plots Foreground 
3. Grid Lines 

 
Figure 26: Editing Overall Styling 
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In the Bar Graph tab, a single customization option, “Dark Mode”, is available (Figure 27). This option was 
added in a prior release and re-located to the Theming section of Preferences. 

 

Figure 27: Dark Bar Graph Option 

When finished with the theme customization, click Save to commit the settings as part of the “Custom” 
theme. Each theme is stored per user per machine. To apply the theme, click “Save” in the Preferences dialog. 
The custom theme will be reflected in the Plots workspace (Figure 28). 

 
Figure 28: Custom Theme in Plot Workspace 
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5.1.3 Orbit Overlay on Shaft Centerline Plot 

System 1 v20.1 now supports DC Orbit Overlays on Shaft Centerline plots. This capability is backwards 
compatible for System 1 Server databases up to v18.2. 

This feature can be enabled using the global hot key “O”. When the hot key is pressed, the closest DC Orbit 
sample to the current cursor location will be overlaid on the Shaft Centerline plot (Figure 29). For every Orbit 
curve that is overlaid on the Shaft Centerline plot, a new row will be displayed in the plot header, detailing the 
sample information of the overlaid Orbit. From the header the user can morph the overlaid orbit curve to a 
filtered waveform. To remove overlaid Orbit curves, the user can press the “x” icon in the header. 

All global toolbar and waveform preferences are applicable to overlaid orbit curves. In addition, overlaid 
curves and settings are preserved within Plot Records. 

 
Figure 29: DC Orbit Overlaid on Shaft Centerline Plot 

5.1.4 Polar Plot Enhancement 

System 1 v20.1 now supports Vector Cursors and visually depicting Keyphasor Position on Polar plots. These 
capabilities are backwards compatible for System 1 Server databases up to v18.2. 

The Vector cursor is enabled from the local Context Menu or by using the global hotkey “I”. The Vector is 
depicted as an arrow originating from the center of the plot to the cursor position on the curve (Figure 30). As 
the point cursor is moved along the curve, the vector arrow will follow. 

Keyphasor position mark is enabled from the local Context Menu or by using the global hotkey “K”. Keyphasor 
mark is depicted on the plot as a black square at the position where the Keyphasor is mounted (Figure 31). 
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Figure 30: Vector Cursors on Polar Plot 

 

Figure 31: Keyphasor Position Mark on Polar Plot 
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